This looks like a reasonable thing. But perhaps instead of an array it might be better to use descriptive names for each line? Note that there is no guarantee on the ordering of the lines in this file.

Suggestions?